nagios4/debian/patches/55_strip_logarchivepath.patch
Mario Fetka a29fcaf2c6 Bump
2019-08-06 16:12:26 +02:00

16 lines
756 B
Diff

Author: Omni Flux <omniflux@omniflux.com>
Description: stripping the log_archive_path value from cgi.cfg (#578232)
Index: nagios4/cgi/cgiutils.c
===================================================================
--- nagios4.orig/cgi/cgiutils.c
+++ nagios4/cgi/cgiutils.c
@@ -519,7 +519,7 @@ int read_main_config_file(const char *fi
temp_buffer = strtok(NULL, "\n");
strncpy(log_archive_path, (temp_buffer == NULL) ? "" : temp_buffer, sizeof(log_archive_path));
log_archive_path[sizeof(log_archive_path) - 1] = '\x0';
- strip(physical_html_path);
+ strip(log_archive_path);
if(log_archive_path[strlen(log_archive_path) - 1] != '/' && (strlen(log_archive_path) < sizeof(log_archive_path) - 1))
strcat(log_archive_path, "/");
}