nagios4/debian/patches/51_commands.cfg-debianize.patch
Mario Fetka a29fcaf2c6 Bump
2019-08-06 16:12:26 +02:00

238 lines
5.9 KiB
Diff

Author: Alexander Wirt <formorer@debian.org>
Description: Debianize commands.cfg
Index: nagios4/sample-config/template-object/commands.cfg.in
===================================================================
--- nagios4.orig/sample-config/template-object/commands.cfg.in
+++ nagios4/sample-config/template-object/commands.cfg.in
@@ -2,24 +2,13 @@
# COMMANDS.CFG - SAMPLE COMMAND DEFINITIONS FOR NAGIOS @VERSION@
#
#
-# NOTES: This config file provides you with some example command definitions
-# that you can reference in host, service, and contact definitions.
-#
-# You don't need to keep commands in a separate file from your other
-# object definitions. This has been done just to make things easier to
-# understand.
-#
###############################################################################
################################################################################
#
-# SAMPLE NOTIFICATION COMMANDS
-#
-# These are some example notification commands. They may or may not work on
-# your system without modification. As an example, some systems will require
-# you to use "/usr/bin/mailx" instead of "/usr/bin/mail" in the commands below.
+# NOTIFICATION COMMANDS
#
################################################################################
@@ -41,200 +30,16 @@ define command {
################################################################################
#
-# SAMPLE HOST CHECK COMMANDS
+# HOST CHECK COMMANDS
#
################################################################################
-# This command checks to see if a host is "alive" by pinging it
-# The check must result in a 100% packet loss or 5 second (5000ms) round trip
-# average time to produce a critical error.
-# Note: Five ICMP echo packets are sent (determined by the '-p 5' argument)
-
-define command {
-
- command_name check-host-alive
- command_line $USER1$/check_ping -H $HOSTADDRESS$ -w 3000.0,80% -c 5000.0,100% -p 5
-}
-
-
+# On Debian, check-host-alive is being defined from within the
+# nagios-plugins-basic package
################################################################################
#
-# SAMPLE SERVICE CHECK COMMANDS
-#
-# These are some example service check commands. They may or may not work on
-# your system, as they must be modified for your plugins. See the HTML
-# documentation on the plugins for examples of how to configure command definitions.
-#
-# NOTE: The following 'check_local_...' functions are designed to monitor
-# various metrics on the host that Nagios is running on (i.e. this one).
-################################################################################
-
-define command {
-
- command_name check_local_disk
- command_line $USER1$/check_disk -w $ARG1$ -c $ARG2$ -p $ARG3$
-}
-
-
-
-define command {
-
- command_name check_local_load
- command_line $USER1$/check_load -w $ARG1$ -c $ARG2$
-}
-
-
-
-define command {
-
- command_name check_local_procs
- command_line $USER1$/check_procs -w $ARG1$ -c $ARG2$ -s $ARG3$
-}
-
-
-
-define command {
-
- command_name check_local_users
- command_line $USER1$/check_users -w $ARG1$ -c $ARG2$
-}
-
-
-
-define command {
-
- command_name check_local_swap
- command_line $USER1$/check_swap -w $ARG1$ -c $ARG2$
-}
-
-
-
-define command {
-
- command_name check_local_mrtgtraf
- command_line $USER1$/check_mrtgtraf -F $ARG1$ -a $ARG2$ -w $ARG3$ -c $ARG4$ -e $ARG5$
-}
-
-
-
-################################################################################
-# NOTE: The following 'check_...' commands are used to monitor services on
-# both local and remote hosts.
-################################################################################
-
-define command {
-
- command_name check_ftp
- command_line $USER1$/check_ftp -H $HOSTADDRESS$ $ARG1$
-}
-
-
-
-define command {
-
- command_name check_hpjd
- command_line $USER1$/check_hpjd -H $HOSTADDRESS$ $ARG1$
-}
-
-
-
-define command {
-
- command_name check_snmp
- command_line $USER1$/check_snmp -H $HOSTADDRESS$ $ARG1$
-}
-
-
-
-define command {
-
- command_name check_http
- command_line $USER1$/check_http -I $HOSTADDRESS$ $ARG1$
-}
-
-
-
-define command {
-
- command_name check_ssh
- command_line $USER1$/check_ssh $ARG1$ $HOSTADDRESS$
-}
-
-
-
-define command {
-
- command_name check_dhcp
- command_line $USER1$/check_dhcp $ARG1$
-}
-
-
-
-define command {
-
- command_name check_ping
- command_line $USER1$/check_ping -H $HOSTADDRESS$ -w $ARG1$ -c $ARG2$ -p 5
-}
-
-
-
-define command {
-
- command_name check_pop
- command_line $USER1$/check_pop -H $HOSTADDRESS$ $ARG1$
-}
-
-
-
-define command {
-
- command_name check_imap
- command_line $USER1$/check_imap -H $HOSTADDRESS$ $ARG1$
-}
-
-
-
-define command {
-
- command_name check_smtp
- command_line $USER1$/check_smtp -H $HOSTADDRESS$ $ARG1$
-}
-
-
-
-define command {
-
- command_name check_tcp
- command_line $USER1$/check_tcp -H $HOSTADDRESS$ -p $ARG1$ $ARG2$
-}
-
-
-
-define command {
-
- command_name check_udp
- command_line $USER1$/check_udp -H $HOSTADDRESS$ -p $ARG1$ $ARG2$
-}
-
-
-
-define command {
-
- command_name check_nt
- command_line $USER1$/check_nt -H $HOSTADDRESS$ -p 12489 -v $ARG1$ $ARG2$
-}
-
-
-
-################################################################################
-#
-# SAMPLE PERFORMANCE DATA COMMANDS
-#
-# These are sample performance data commands that can be used to send performance
-# data output to two text files (one for hosts, another for services). If you
-# plan on simply writing performance data out to a file, consider using the
-# host_perfdata_file and service_perfdata_file options in the main config file.
+# PERFORMANCE DATA COMMANDS
#
################################################################################