mydumper/debian/patches/0003-explicitly-link-libm.patch
Mario Fetka 9f30cb98ea Bump
2019-08-09 13:49:00 +02:00

35 lines
1.3 KiB
Diff

From: Mateusz Kijowski <mateusz.kijowski@gmail.com>
Date: Mon, 20 Jan 2014 21:42:40 +0100
Subject: explicitly link libm
---
CMakeLists.txt | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5da3828..0a6f7e7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,7 @@
find_package(ZLIB)
find_package(GLIB2)
find_package(PCRE)
+find_library(M_LIB m)
option(BUILD_DOCS "Build the documentation" ON)
@@ -37,11 +38,11 @@
else (WITH_BINLOG)
add_executable(mydumper mydumper.c server_detect.c g_unix_signal.c connection.c getPassword.c)
endif (WITH_BINLOG)
-target_link_libraries(mydumper ${MYSQL_LIBRARIES} ${GLIB2_LIBRARIES} ${GTHREAD2_LIBRARIES} ${PCRE_PCRE_LIBRARY} ${ZLIB_LIBRARIES} stdc++)
+target_link_libraries(mydumper ${MYSQL_LIBRARIES} ${GLIB2_LIBRARIES} ${GTHREAD2_LIBRARIES} ${PCRE_PCRE_LIBRARY} ${ZLIB_LIBRARIES} ${M_LIB} stdc++)
add_executable(myloader myloader.c connection.c getPassword.c)
-target_link_libraries(myloader ${MYSQL_LIBRARIES} ${GLIB2_LIBRARIES} ${GTHREAD2_LIBRARIES} ${PCRE_PCRE_LIBRARY} ${ZLIB_LIBRARIES} stdc++)
+target_link_libraries(myloader ${MYSQL_LIBRARIES} ${GLIB2_LIBRARIES} ${GTHREAD2_LIBRARIES} ${PCRE_PCRE_LIBRARY} ${ZLIB_LIBRARIES} ${M_LIB} stdc++)
INSTALL(TARGETS mydumper myloader
RUNTIME DESTINATION bin