28 lines
716 B
Diff
28 lines
716 B
Diff
From: Christian Kastner <ckk@kvr.at>
|
|
Date: Tue, 5 Nov 2019 07:52:09 +0100
|
|
Subject: Hurd workaround for PATH_MAX
|
|
|
|
PATH_MAX is not defined on GNU Hurd, which is legal according to POSIX.
|
|
|
|
https://www.gnu.org/software/hurd/hurd/porting/guidelines.html
|
|
|
|
Bug-Debian: https://bugs.debian.org/638048
|
|
---
|
|
src/macros.h | 5 +++++
|
|
1 file changed, 5 insertions(+)
|
|
|
|
--- a/src/macros.h
|
|
+++ b/src/macros.h
|
|
@@ -43,6 +43,11 @@
|
|
#define DEBUGGING FALSE
|
|
#endif
|
|
|
|
+/* Gnu Hurd has no limit on pathnames */
|
|
+#if !defined PATH_MAX && defined __GNU__
|
|
+#define PATH_MAX 4096
|
|
+#endif
|
|
+
|
|
#define INIT_PID 1 /* parent of orphans */
|
|
#define READ_PIPE 0 /* which end of a pipe pair do you read? */
|
|
#define WRITE_PIPE 1 /* or write to? */
|