linamh/app-cdr/qlscribe/files/qlscribe-0.11-gentoo-4.patch
2009-04-25 08:56:23 +00:00

25 lines
948 B
Diff

Submitted By: Mario Fetka (mario dot fetka at gmail dot com)
Date: 2009-04-16
Initial Package Version: 0.11
Origin: me
Upstream Status: unknown
Description: add an RPATH to the lscribe daemon so that it works around the LDPATH problem
yes it adds an unneeded overhead to the linker but it works
diff -Naur qlscribe-0.11.orig/lscribed/CMakeLists.txt qlscribe-0.11/lscribed/CMakeLists.txt
--- qlscribe-0.11.orig/lscribed/CMakeLists.txt 2009-04-04 03:43:35.000000000 +0000
+++ qlscribe-0.11/lscribed/CMakeLists.txt 2009-04-15 23:07:14.897023631 +0000
@@ -61,6 +63,12 @@
ADD_EXECUTABLE( lscribed ${LSCRIBED_SRCS} )
+IF (LSRPATH)
+ SET_TARGET_PROPERTIES( lscribed PROPERTIES INSTALL_NAME_DIR ${LSRPATH} )
+ SET(CMAKE_BUILD_WITH_INSTALL_RPATH TRUE)
+ SET(CMAKE_INSTALL_RPATH "${LSRPATH}")
+ENDIF (LSRPATH)
+
TARGET_LINK_LIBRARIES( lscribed ${LSCRIBE_LIBRARIES} ${DBUS_LIBRARIES} pthread )
INSTALL( TARGETS lscribed DESTINATION sbin )