677e030bbd
git-svn-id: https://svn.disconnected-by-peer.at/svn/linamh/trunk/linamh@2464 6952d904-891a-0410-993b-d76249ca496b
47 lines
1.6 KiB
Diff
47 lines
1.6 KiB
Diff
diff -uNr libre.orig//configure.in libre/configure.in
|
|
--- libre.orig//configure.in 2010-09-29 18:48:36.000000000 +0200
|
|
+++ libre/configure.in 2010-09-29 18:54:56.000000000 +0200
|
|
@@ -1349,12 +1349,18 @@
|
|
done
|
|
fi
|
|
SUNTEMPLATES_LANG=
|
|
- # check whether the langs are requested at all
|
|
- for lang in $wanted_sun_templates ; do
|
|
- if test -n "`echo $with_lang | grep "$lang"`" ; then
|
|
- SUNTEMPLATES_LANG="$SUNTEMPLATES_LANG $lang"
|
|
- fi
|
|
- done
|
|
+
|
|
+ # --with-lang="" now used for en-US
|
|
+ if test "z$with_lang" = "z" ; then
|
|
+ SUNTEMPLATES_LANG="en-US"
|
|
+ else
|
|
+ # check whether the langs are requested at all
|
|
+ for lang in $wanted_sun_templates ; do
|
|
+ if test -n "`echo $with_lang | grep "$lang"`" ; then
|
|
+ SUNTEMPLATES_LANG="$SUNTEMPLATES_LANG $lang"
|
|
+ fi
|
|
+ done
|
|
+ fi
|
|
AC_MSG_RESULT([$SUNTEMPLATES_LANG])
|
|
fi
|
|
AC_SUBST(SUNTEMPLATES_LANG)
|
|
diff -uNr libre.orig//patches/dev300/apply libre/patches/dev300/apply
|
|
--- libre.orig//patches/dev300/apply 2010-09-29 18:48:37.000000000 +0200
|
|
+++ libre/patches/dev300/apply 2010-09-29 18:49:19.000000000 +0200
|
|
@@ -1019,14 +1019,10 @@
|
|
[ GentooOnly ]
|
|
SectionOwner => aprosky
|
|
|
|
-# Allow build to proceed with PaX enabled
|
|
-gentoo-pax-fix.diff, aprosky
|
|
# support server-only versions of 64bit JDKs
|
|
64bit-jdk-server-paths.diff, i#65974, hmth
|
|
# use IBM j9vm over IBM classic JVM
|
|
ibm-j9vm.diff, hmth
|
|
-# system db check
|
|
-system-db-check.diff, i#65979, hmth
|
|
# User ~/.ooo3 as user dir
|
|
scp2-user-config-ooo3.diff, pmladek
|
|
# default inc/lib
|